寒假集训图论H

题目
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
解题思路
要建几条路使得任意两个城镇直接或间接相通,就是求连通块的数量减一。求连通块的数量的方法有搜索,并查集。
以下代码用并查集的方法找连通块。
代码

#include <cstdio>
using namespace std;
int father[1010];
int getfather(int x)
{
	if (father[x]==x) return x;
	father[x]=getfather(father[x]);
	return father[x];
}
int main()
{
	int n;
	while (true)
	{
		scanf("%d",&n);
		if (n==0) break;
		int ans=0,m;
		for (int i=1;i<=n;i++)
		  father[i]=i;
		scanf("%d",&m); 
		for (int i=1;i<=m;i++)
		  {
		  	int a,b;
		  	scanf("%d%d",&a,&b);
		  	int aa=getfather(a);
		  	int bb=getfather(b);
		  	if (aa!=bb) father[aa]=bb;
		  } 
		for (int i=1;i<=n;i++)
		  if (father[i]==i) ans++;
		printf("%d\n",ans-1);    
	}
}
发布了41 篇原创文章 · 获赞 0 · 访问量 597

猜你喜欢

转载自blog.csdn.net/weixin_45723759/article/details/103996246