寒假训练图论A

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
题目大意
有n头牛,有m个关系A B表示牛A打败了牛B,求有多少头牛能确定它的排名。
解题思路
对于牛X,只要它打败的牛(直接或间接),加上打败它的牛(直接或间接)等于n-1,那么这头牛的排名就可以确定下来了。
这就可以转化成多源点最短路路径问题了。
正向连边建图,x到y有路径,则说明x打败了y(直接或间接)
反向连边建图,x到y有路径,则说明x被y打败了(直接或间接)
代码

#include <cstdio>
#include <iostream>
#define INF 999999999
using namespace std;
int a[1010][1010];
int b[1010][1010];
int ans;
int main()
{
	int n,m;
    scanf("%d%d",&n,&m); 
	for (int i=1;i<=n;i++)
	  for (int j=1;j<=n;j++)
		{
		  a[i][j]=INF;
		  b[i][j]=INF;
	    }
		for (int i=1;i<=m;i++)
		  {
		  	int x,y;
		  	scanf("%d%d",&x,&y);
		  	a[x][y]=1;
		  	b[y][x]=1;
		  }
	  for (int k=1;k<=n;k++)
		for (int i=1;i<=n;i++)  
		  for (int j=1;j<=n;j++)
		    if (a[i][j]>a[i][k]+a[k][j]) a[i][j]=a[i][k]+a[k][j];
	  for (int k=1;k<=n;k++)
		for (int i=1;i<=n;i++)  
		  for (int j=1;j<=n;j++)
		    if (b[i][j]>b[i][k]+b[k][j]) b[i][j]=b[i][k]+b[k][j];
		for (int i=1;i<=n;i++)
		  {
		  int num=0; 
		  for (int j=1;j<=n;j++)
		    {
		    if (a[i][j]!=INF) num++;
		    if (b[i][j]!=INF) num++;
		    }
		  if (num==n-1) ans++;
	       }
		printf("%d",ans);	      
}

发布了41 篇原创文章 · 获赞 0 · 访问量 600

猜你喜欢

转载自blog.csdn.net/weixin_45723759/article/details/103996124