C逆序建立链表 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。


Output

依次输出单链表所存放的数据。


Sample Input

10
11 3 5 27 9 12 43 16 84 22


Sample Output

22 84 16 43 12 9 27 5 3 11


Hint

不能使用数组!


Source


方法一:先建立一个头节点,以后的节点连在头结点后面,下面有图形演示;

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;

};

int main()
{
    struct node *head,*p,*q;
    head = (struct node *)malloc(sizeof(struct node));
    head ->next = NULL;
    int n;
    scanf("%d",&n);
    while(n--)//链表建立;
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = head -> next;//以上三句为定义一个新的节点的过程;
        head -> next = p;
    }
    q = head -> next;
 while(q)
    {
        if(q->next!= NULL)
            printf("%d ",q->data);
        else printf("%d\n",q->data);
        q = q->next;
    }
    return 0;

}

方法二:顺序建立,逆序输出;

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;

};

int main()
{
    struct node *head,*p,*q;
    head = (struct node *)malloc(sizeof(struct node));
    head ->next = NULL;
    q = head;//定义一个指针只想第一个节点;
    int n;
    scanf("%d",&n);
    while(n--)//链表建立;
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&q->data);
        p->next = q;//以上三句为定义一个新的节点的过程;
        if(n!=0)
        q = p;
    }
  while (q!=NULL) //链表输出;
    {
        if(q->next!= NULL)
            printf("%d ",q->data);
        else printf("%d\n",q->data);
        q = q->next;
    }
    return 0;

}

think:方法一: 逆序建立链表的过程还是先建立头接头点,让后建立一个节点输入一个数,并将新建的链表连在头结点后面

1.在这里插入图片描述

再将其连接起来

2.在这里插入图片描述

在建立的节点始终连在头节点和第二个节点之间,以后就可以用循环实现

3.在这里插入图片描述

4.在这里插入图片描述

5.在这里插入图片描述

这样就和图2,相类似,即一次循环

发布了162 篇原创文章 · 获赞 119 · 访问量 3219

猜你喜欢

转载自blog.csdn.net/zhangzhaolin12/article/details/104021950