C 约瑟夫问题 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。


Input

输入n和m值。


Output

输出胜利者的编号。


Sample Input

5 3


Sample Output

4


Hint

第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀


Source


循环链表其实非常简单,就是在正常建立链表,最后将为节点的指针指向头结点指向的节点;
本题其实是一个循环链表的元素删除问题,直至剩下一个元素

#include <stdio.h>
#include  <stdlib.h>
  struct node
  {
      int a;
      struct node *next;

  };
  int main()
  {
      int n,m,i,j;
      struct node *head,*q,*p;
      scanf("%d%d",&n,&m);
      head = (struct node *)malloc(sizeof(struct node));
      head -> next =NULL;
      q = head;
      for(i=1;i<=n;i++)
      {
          p = (struct node *)malloc(sizeof(struct node));
          p -> next = NULL;
          p -> a = i;  //链表中存储的数据为编号;
          q -> next = p;
          q = p;
      }
      p -> next = head -> next;
     //最后将为节点的指针指向头结点只想的节点,注意头结点一般不存储数据,为空节点;
      q = head -> next;
      p = head;
      for(;n>1;n--)//只要循环链表中的节点数大于“1”便继续执行;
      {
          for(j=0;j<m-1;j++)//删除一个节点;
          {
              q = q -> next;
              p = p -> next;
          }
          p -> next = q -> next;
          q = q -> next;
      }
     printf("%d\n",p -> a);
      return 0;
  }

发布了162 篇原创文章 · 获赞 119 · 访问量 3209

猜你喜欢

转载自blog.csdn.net/zhangzhaolin12/article/details/104028364