【POJ 3278 --- Catch That Cow】队列 || bfs

【POJ 3278 --- Catch That Cow】队列 || bfs

题目来源:点击进入【POJ 3278 — Catch That Cow】

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

扫描二维码关注公众号,回复: 8671038 查看本文章

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

解题思路

根据题意知,我们需要求从一个点到另一个的最短前进次数。一共有三种前进方式,分别是x-1,x+1和2x。
类似于bfs的思路。我们只需通过一个队列将x-1,x+1,2
x,作为x的子节点依次进入队列即可,最先找到的节点即为答案。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
#define endl '\n'
const int MAXN = 100005;
int vis[MAXN];

int main()
{
    SIS;
    int n,k,ans=0;
    while(cin >> n >> k)
    {
        if(k<=n) 
        {
            cout << n-k << endl;
            continue;
        }
        memset(vis,0,sizeof(vis));
        queue<int> q;
        q.push(n);
        while(!q.empty())
        {
            int x=q.front();
            q.pop();
            if(x-1<MAXN && x-1>0 && !vis[x-1]) vis[x-1]=vis[x]+1, q.push(x-1);
            if(x+1<MAXN && !vis[x+1]) vis[x+1]=vis[x]+1, q.push(x+1);
            if(2*x<MAXN && !vis[2*x]) vis[2*x]=vis[x]+1, q.push(2*x);
            if(x-1==k || x+1==k || x*2==k) break;
        }
        cout << vis[k] << endl;
    }
    return 0;
}
发布了361 篇原创文章 · 获赞 127 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/104011531