Catch That Cow POJ - 3278 BFS搜索

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 112355   Accepted: 35099

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


比较坑的是队列不能定义在函数内部,要定义为全局变量,不然会WA。可能这题对队列容量需求确实比较大,定义为全局变量可以获得更大的队列空间。不过要记得每次清空。


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <sstream>
#include <map>

#define INF 10000
using namespace std;

int n,k;
int vis[200005];
struct DATA
{
	int v,step;
	DATA(int vv,int ss)
	{
		v=vv;
		step=ss;
	}
};
typedef struct DATA DATA;

queue<DATA> Q;

int BFS()
{
	DATA s(n,0);

	Q.push(s);
	vis[n]=1;
	while(Q.size()>0)
	{
		DATA cur=Q.front();
		Q.pop();
		if(cur.v==k)
		{
			return cur.step;
		}
		int cv=cur.v;
		int cs=cur.step;
		if(cv>0 && vis[cv-1]==0)
		{
			DATA tmp(cv-1,cs+1);
			vis[cv-1]=1;
			Q.push(tmp);
		}
		if(cv<=k && vis[cv+1]==0)
		{
			DATA tmp(cv+1,cs+1);
			vis[cv+1]=1;
			Q.push(tmp);
		}
		if(cv<=k && vis[cv*2]==0)
		{
			DATA tmp(cv*2,cs+1);
			vis[cv*2]=1;
			Q.push(tmp);
		}
		
		
	}
	
}


int main()
{
	while(scanf("%d%d",&n,&k)==2)
	{
		memset(vis,0,sizeof(vis));
		if(n>=k)
		{
			printf("%d\n",n-k);
			continue;
		}
		while(Q.size()>0) Q.pop();
		int ans=BFS();
		printf("%d\n",ans);
	}
	
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zl1085372438/article/details/80436868