POJ 3278 Catch That Cow —————— BFS

Language:Default
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 120100 Accepted: 37481

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

—-
/*
    2018/9/9

    BFS
    x 有三个搜索方向
    x+1;
    x-1;
    x*2;
    优先队列,找最短时间
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
const int MAXN=1e6+9;
int n,k;
bool vis[MAXN];
struct node{
    int x,step;
    node(){};
    node(int _x,int _step)
    {
        x=_x; step=_step;
    }
    bool operator < (const node &b)const
    {
        return step==b.step?x<b.x:step>b.step;
    }
};

int bfs(int x)
{
    memset(vis,0,sizeof(vis));
    vis[x]=1;
    node e1,e2;
    priority_queue<node> que;
    que.push(node(x,0));
    int ans=0;
    while(que.size())
    {
        e1=que.top();que.pop();
        if(e1.x==k)
        {
            ans=e1.step;
            break;
        }
        if(!vis[e1.x+1])
        {
            vis[e1.x+1]=1;
            que.push(node(e1.x+1,e1.step+1));
        }
        if(e1.x>0 && !vis[e1.x-1])
        {
            vis[e1.x-1]=1;
            que.push(node(e1.x-1,e1.step+1));
        }
        if(e1.x<=200000 && !vis[e1.x*2])
        {
            vis[2*e1.x]=1;
            que.push(node(e1.x*2,e1.step+1));
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d %d",&n,&k))
        printf("%d\n",bfs(n));
    return 0;
}




猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/82563469