POJ3278 Catch That Cow【BFS】

Catch That Cow

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 121104   Accepted: 37792

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

问题链接:POJ3278 Catch That Cow

问题描述:在数轴上,农民在N处,牛在K处,农民想在最短的时间内达到牛的位置。从一个点X可以花1分钟达到X-1,X+1,2X的位置处。对于给定的N和K问最短的时间

解题思路:bfs

AC的C++代码:

#include<iostream>
#include<algorithm>
#include<queue>

using namespace std;
const int N=100005;

struct Node{
	int pos,t;
};

bool vis[N];

int bfs(Node s,int e)
{
	queue<Node>q;
	q.push(s);
	vis[s.pos]=true;
	while(!q.empty()){
		Node f=q.front();
		q.pop();
		if(f.pos==e)
		  return f.t;
		for(int i=1;i<=3;i++){
			Node tmp=f;
			if(i==1)
			  tmp.pos-=1;
			else if(i==2)
			  tmp.pos+=1;
			else if(i==3)
			  tmp.pos*=2;
			if(tmp.pos>=0&&tmp.pos<=N&&!vis[tmp.pos]){
				vis[tmp.pos]=true;
				tmp.t=f.t+1;
				q.push(tmp);
			}
		}
	}
}

int main()
{
	int n,k;
	scanf("%d%d",&n,&k);
	Node s;
	s.pos=n,s.t=0;
	printf("%d\n",bfs(s,k));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82860430
今日推荐