Poj 1384 Piggy-Bank【完全背包】

完全背包简单题目

题目:
Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

就是说输入测试数据数
输入空的存钱罐的重量以及满了的重量
输入硬币种类数t
以下t行输入t种硬币每个硬币的重量以及面值
求此情况下该存钱罐至少能存的钱数,无解就输出无解
简单思路:
就是完全背包的板子,唯一不同的的是,他要求的是最小值,而完全背包的板子,是让我们算最大价值。这里只需要一个转换,把求最大值改为求最小值。那我们可以逆向思维,完全背包初始化时DP数组全赋值为0,这里我们赋值为inf,然后每次更新最小值就可以了,剩下的都是板子了。即:

for(int i=0;i<n;i++){
            for(int j=w[i];j<=sum;j++){
                dp[j]=min(dp[j-w[i]]+v[i],dp[j]);
            }
        }

完整代码展示:

#include<bits/stdc++.h>
using namespace std;
#define N 10005
const int inf=0x3f3f3f3f;
int dp[N],v[N],w[N];
int main(){
    int t,e,f,n,sum=0;
    cin>>t;
    while(t--){
        cin>>e>>f>>n;
        sum=f-e;
        dp[0]=0; //这个是为了防止特判的情况,即e=v的情况
        for(int i=1;i<=sum;i++) dp[i]=inf;
        for(int i=0;i<n;i++) cin>>v[i]>>w[i];
        for(int i=0;i<n;i++){
            for(int j=w[i];j<=sum;j++){
                dp[j]=min(dp[j-w[i]]+v[i],dp[j]);
            }
        }
        if(dp[sum]==inf) cout<<"This is impossible.\n";
        else cout<<"The minimum amount of money in the piggy-bank is "<<dp[sum]<<".\n";
    }
    return 0;
}
发布了43 篇原创文章 · 获赞 56 · 访问量 5143

猜你喜欢

转载自blog.csdn.net/tran_sient/article/details/94836369
今日推荐