【POJ - 1384】Piggy-Bank (完全背包+背包装满)

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意:

现在有n种硬币,每种硬币有特定的重量cost[i] 克和它对应的价值val[i]. 每种硬币可以无限使用. 已知现在一个储蓄罐中所有硬币的总重量正好为m克, 问你这个储蓄罐中最少有多少价值的硬币? 如果不可能存在m克的情况, 那么就输出” This is impossible.”.

思路:

一道完全背包的题目,因为是要求最小值,所以初始化的时候应该初始化为一个比较大的值,在用一维的数组时应该正向遍历。

扫描二维码关注公众号,回复: 2912923 查看本文章

因为这道题目要求是完全装满,所以对初始化有一定要求。但自己也没想明白为什么这样初始化,尤其是dp[0]=0,为什么这样就能保证正好装满。

到网上搜了一下发现大神的博客里给出了解释:

https://blog.csdn.net/xxiaobaib/article/details/54968100

背包的装满问题 
1.假设v[i]全为正值.

1.1.如果是求最大值,dp[j] = max(dp[j],dp[j-w[i]]+v[i]) 
则初始化全为-INF,然后dp[0] = 0,这样可以保证只有装满的背包才是正值,其他全为负值,最终求得的dp[MAX]是从dp[0]开始一点一点把w[i]加上去的,一定是加满的,而那些半路出家没有装满背包的全是负值;

1.2.如果是求最小值,dp[j] = min(dp[j],dp[j-w[i]]+v[i]) 
则初始化全为INF,然后dp[0] = 0等,同理这样可以保证是从容量为0开始,然后一点一点加到dp[MAX],这样求得的dp[MAX]一定是加满的。

2.假设v[i]有正有负,初始化和以上是相同的,我们还需要将dp[j]的下标右移,保证j一定为正值。然后针对v[i]的正负作不同的顺序逆序循环

而这一题就是简单的装满完全背包,所以 
设dp[j]为前n种钱币所占重量为j时得到的最小价值则有递推公式: 
dp[j] = min(dp[j],dp[j-w[i]]+v[i])

ac代码:

#include<cstdio>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring> 
#include<queue>
#include<stack>
#define inf 0x3f3f3f3f
using namespace std;
int w[3500],val[3500];
int dp[20000];
int main()
{
	int t,n,m,e,f;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,inf,sizeof(dp));
		dp[0]=0;//注意这里也要初始化
		scanf("%d%d",&e,&f);
		m=f-e;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&val[i],&w[i]);
		}
		for(int i=0;i<n;i++)
		{
			for(int j=w[i];j<=m;j++)
			{
				dp[j]=min(dp[j],dp[j-w[i]]+val[i]);
			}
			
		}
		if(dp[m]==inf)
		{
			printf("This is impossible.\n");
		}
		else
		{
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/QQ_774682/article/details/81675712
今日推荐