poj1384

Piggy-Bank

Time Limit: 1000MS Memory Limit: 10000K

题目链接

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

Source

Central Europe 1999

Solution

题意:完全背包问题求最小价值

时间复杂度O(nm)

二维数组如下,MLE

#include<iostream>
#include<algorithm>
using namespace std;
int dp[505][10005];
int v[505];
int w[505];
int t;
int e,f;
int n,m;
const int inf=0x3f3f3f3f;
int main()
{
	//freopen("input.txt","r",stdin);
	cin>>t;
	while(t--)
	{
		cin>>e>>f;
		m=f-e;
		cin>>n;
		//init
		fill(dp[0],dp[0]+n*(m+1),inf);
		dp[0][0]=0;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&v[i],&w[i]);
		for(int i=1;i<=n;i++)
			for(int j=0;j<=m;j++)
				if(j<w[i])
					dp[i][j]=dp[i-1][j];
				else
					dp[i][j]=min(dp[i-1][j],dp[i][j-w[i]]+v[i]);
		if(dp[n][m]!=inf)
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n][m]);
		else
		    printf("This is impossible.\n");
	}
	return 0;
}

改一维数组,AC

#include<iostream>
#include<algorithm>
using namespace std;
int dp[10005];
int v[505];
int w[505];
int t;
int e,f;
int n,m;
const int inf=0x3f3f3f3f;
int main()
{
	//freopen("input.txt","r",stdin);
	cin>>t;
	while(t--)
	{
		cin>>e>>f;
		m=f-e;
		cin>>n;
		//init
		fill(dp,dp+m+1,inf);     //!!!!!
		dp[0]=0;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&v[i],&w[i]);
		for(int i=1;i<=n;i++)
			for(int j=w[i];j<=m;j++)
					dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
		if(dp[m]!=inf)
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
		else
		    printf("This is impossible.\n");
	}
	return 0;
}

这个地方要注意 fill 到 dp+m+1

滚动数组好啊

AC代码

#include<iostream>
#include<algorithm>
using namespace std;
int dp[2][10005];
int v[505];
int w[505];
int t;
int e,f;
int n,m;
const int inf=0x3f3f3f3f;
int main()
{
	//freopen("input.txt","r",stdin);
	cin>>t;
	while(t--)
	{
		cin>>e>>f;
		m=f-e;
		cin>>n;
		//init
		fill(dp[0],dp[0]+2*(m+1),inf);
		dp[0][0]=0;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&v[i],&w[i]);
		for(int i=1;i<=n;i++)
			for(int j=0;j<=m;j++)
				if(j<w[i])
					dp[i&1][j]=dp[(i-1)&1][j];
				else
					dp[i&1][j]=min(dp[(i-1)&1][j],dp[i&1][j-w[i]]+v[i]);
		if(dp[n&1][m]!=inf)
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n&1][m]);
		else
		    printf("This is impossible.\n");
	}
	return 0;
}

Summary

这种类型的dp有两个重点,初始化边界条件,找递推式

求最小,一般初始化为inf,dp[0][0]=0;

求最大,一般初始化为0

必要时可用滚动数组

完全背包递推式的证明(这里证明求最大值的情况)

dp[i][j]=max{dp[i-1][j-k*w[i]]+k*v[i] | k>=0}

=max(dp[i-1][j] , max{dp[i-1][j-k*w[i]]+k*v[i] | k>=1}

=max(dp[i-1][j] , max{dp[i-1][(j-w[i])-k*w[i]]+k*v[i] | k>=0}+v[i])

=max(dp[i-1][j] , dp[i][j-w[i]]+v[i])

这种分离思想很常见

发布了13 篇原创文章 · 获赞 0 · 访问量 182

猜你喜欢

转载自blog.csdn.net/qq_43737697/article/details/104079956
今日推荐