HDOJ 1114 Piggy-Bank (完全背包)

Piggy-Bank

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题目大概意思:一个存钱罐,知道空存钱罐的重量,满存钱罐的重量,已知货币的种类,每种货币的重量,货币数量不限,求满的存钱罐内价值最少是多少。

题解:这一题属于完全背包问题,正常的完全背包问题都是求价值最大,而这一题是求价值最小,正好相反。刚开始博主看见这一题也有点蒙,毕竟刚学动态规划。我想的是,把完全背包的状态转移方程改改就行了吧:

一维的状态转移方程:

//完全背包(最大值)
dp[j]=max(dp[j],dp[j-W[i]+v[i]);
//完全背包(最小值)(博主的猜想)
dp[j]=min(dp[j],dp[j-W[i]+v[i]);

事实证明还是猜对了一些,直接贴代码了:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm> 
#define INF 0x7ffffff
using namespace std;
typedef struct{
	int W;
	int P;
}point; 
int dp[10010];
int main()
{
	int N;
	cin>>N;
	while(N--)
	{
		
		int n,w1,w2,w;
		cin>>w1>>w2;
		w=w2-w1;
		cin>>n;
		for(int i=1;i<=w2-w1;i++)
           dp[i]=INF;//一定要初始化为无穷大值
		point *a;
		a=new point[n+2];
		a[0].P=0;
		a[0].W=0;
		int i,j;
		for(i=1;i<=n;i++)
			cin>>a[i].P>>a[i].W;
		for(i=1;i<=n;i++)
			for(j=a[i].W;j<=w;j++)	//注意这里j是从a[i].W到w
                		dp[j]=min(dp[j],dp[j-a[i].W]+a[i].P);

	
		if(dp[w2-w1]==INF) printf("This is impossible.\n");
        else
           printf("The minimum amount of money in the piggy-bank is %d.\n",dp[w2-w1]); 
	}
	return 0;
}

下面贴一个针对这一题,如果要是求最大值的代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm> 
#define INF 0
using namespace std;
typedef struct{
	int W;
	int P;
}point; 
int dp[10010];
int main()
{
	int N;
	cin>>N;
	while(N--)
	{
		
		int n,w1,w2,w;
		cin>>w1>>w2;
		w=w2-w1;
		cin>>n;
		for(int i=1;i<=w2-w1;i++)
           dp[i]=INF; //初始化为0 
		point *a;
		a=new point[n+2];
		a[0].P=0;
		a[0].W=0;
		int i,j;
		for(i=1;i<=n;i++)
			cin>>a[i].P>>a[i].W;
		for(i=1;i<=n;i++)
			for(j=a[i].W;j<=w;j++)
				dp[j]=max(dp[j],dp[j-a[i].W]+a[i].P); //改成max 
		if(dp[w2-w1]==INF) printf("This is impossible.\n");
        else
           printf("The max amount of money in the piggy-bank is %d.\n",dp[w2-w1]); 
	}
	return 0;
}

对比两个代码可以很清楚的看成相同和不同点,不同主要在两点:对dp[ ]初始化的不同,对状态转移方程的不同。

有什么问题可以在下面评论讨论讨论,博主会回复的。

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/81226854