1025 PAT Ranking (25分) 【成绩排名】

题目:https://pintia.cn/problem-sets/994805342720868352/problems/994805474338127872

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

struct student
{
	char id[15]; //准考证号
	int score; //分数
	int local_number; //考场号
	int local_rank; //考场内的排名	
}stu[30010];

bool cmp(student a,student b)
{
	if(a.score!=b.score) return a.score>b.score;
	else return strcmp(a.id,b.id)<0;
} 

int main()
{
	int n; //考场数 
	int k;
	int num=0; //总人数 
	cin>>n;
	
	//按考场数遍历 
	for(int i=1;i<=n;i++)
	{
		cin>>k; //考场内人数
		
		//先输入考场内人员的信息 
		for(int j=0;j<k;j++)
		{
			cin>>stu[num].id>>stu[num].score;
			stu[num].local_number=i;
			num++;
		} 
		
		//然后排序 
		sort(stu+num-k,stu+num,cmp);
		
		//然后定排名 
		stu[num-k].local_rank=1;
		for(int j=num-k+1;j<num;j++)
		{
			if(stu[j].score==stu[j-1].score)
			{
				stu[j].local_rank=stu[j-1].local_rank;
			}
			else
			{
				stu[j].local_rank=j-(num-k)+1;
			}
		}
		
	} 

	cout<<num<<endl;
	
	//整个所有数据排序 
	sort(stu,stu+num,cmp);
	int r=1;
	cout<<stu[0].id<<' '<<r<<' '<<stu[0].local_number<<' '<<stu[0].local_rank<<endl;
	
	for(int i=1;i<num;i++)
	{
		if(stu[i].score!=stu[i-1].score)
		{
			r=i+1; 
		}
		cout<<stu[i].id<<' '<<r<<' '<<stu[i].local_number<<' '<<stu[i].local_rank<<endl;
	}
	return 0;
}
发布了146 篇原创文章 · 获赞 60 · 访问量 14万+

猜你喜欢

转载自blog.csdn.net/OpenStack_/article/details/103752426