1025 PAT Ranking (25 分)(排序,排名类模拟)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

simultaneously
同时

generate
生成

registration_number
注册号

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
struct node{
	ll rnum;
	int fr,lnum,lr;
	int sc;
}p[30005];
vector<node> v;
bool cmp1(node a,node b){
	return a.sc>b.sc;
}
bool cmp2(node a,node b){
	if(a.sc!=b.sc) return a.sc>b.sc;
	else return a.rnum<b.rnum; 
}
int main(){
    int n;
    int cas=0;
    scanf("%d",&n);
    int tot=0;
    while(n--){//处理组内排名 
    	cas++;
    	int k;
    	scanf("%d",&k);
    	v.clear();
    	for(int i=1;i<=k;i++){
    		ll num;
    		int sc;
    		scanf("%lld%d",&num,&sc);
    		v.push_back(node{num,0,cas,0,sc});
		}
		sort(v.begin(),v.end(),cmp1);
		int rank=0;
		int lastsc=10086;
		for(int i=0;i<v.size();i++){
			if(v[i].sc!=lastsc){
				rank=i+1;
				lastsc=v[i].sc;
		    }
			v[i].lr=rank;
			p[++tot]=v[i];
		}
	}
    sort(p+1,p+tot+1,cmp2);
	int rank=0;
	int lastsc=10086;
	for(int i=1;i<=tot;i++){
		if(p[i].sc!=lastsc){
			rank=i;
			lastsc=p[i].sc;
		}
		p[i].fr=rank;
	} 
	printf("%d\n",tot);
	for(int i=1;i<=tot;i++){
		printf("%013lld %d %d %d\n",p[i].rnum,p[i].fr,p[i].lnum,p[i].lr);
	}
	return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/102815055