PAT A1025 PAT Ranking (25分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意:

输入考场数,按考场顺序分别输入学生数目,逐行输入学生账号和分数,输出学生总数,逐行输出学生账号、总排名、考场号、考场内排名.

思路:

(1)开设一个student结构体,存放学生的账号、分数、考场号、考场内排名;
(2)每次输入完一个考场的学生,将每个学生的场内排名求出并记录在结构体数组中;
(3)求出所有学生总排名,每求出一个学生的总排名就输出该学生的相关信息.

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct student{
	char register_number[15]; 
	int score,location_number,local_rank;
}stu[30010];
bool cmp(student a,student b){
	if(a.score!=b.score)
		return a.score>b.score;
	else
		return strcmp(a.register_number,b.register_number)<0;
}

int main(){
	int N;
	scanf("%d",&N);
	int k,total = 0;
	for(int i=1;i<=N;i++){
		scanf("%d",&k);
		for(int j=0;j<k;j++){
			scanf("%s %d",stu[total].register_number,&stu[total].score);
			stu[total].location_number = i;
			total++; 
		}
		sort(stu+total-k,stu+total,cmp);
		stu[total-k].local_rank = 1;
		for(int j=1;j<k;j++){
			if(stu[total-k+j].score==stu[total-k+j-1].score){
				stu[total-k+j].local_rank = stu[total-k+j-1].local_rank;
			}else{
				stu[total-k+j].local_rank = j+1;
			}
		}
	}
	printf("%d\n",total);
	sort(stu,stu+total,cmp);
	int final_rank = 1;
	printf("%s %d %d %d\n",stu[0].register_number,final_rank,stu[0].location_number,stu[0].local_rank);				
	for(int i=1;i<total;i++){
		if(stu[i].score!=stu[i-1].score){
			final_rank = i+1;
		}
		printf("%s %d %d %d\n",stu[i].register_number,final_rank,stu[i].location_number,stu[i].local_rank);				
	}	
	return 0;
} 

词汇:

simultaneously 同时地
ranklist 排行耪

发布了26 篇原创文章 · 获赞 0 · 访问量 470

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/104226480
今日推荐