A1025PAT Ranking (25)

1025 PAT Ranking (25)(25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 思路:

         用到了C++提供的sort()函数,进行排序,

  难点:需要注意的是:把每次输入的数据都要存放在一个结构体数组中,所以就要对数组进行分段工作.

在输入信息的for里面放置一个num++;来记录总人数.用上一个输入的k和总人数num做差,就是下一组数据的范围.

    [num-k,num)

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; 
struct Student{
	char id[15];//学号 
	int score;//分数 
	int rank;//总排名 
	int out_rank;//考场内排名 
	int market;//考场号 
}stu[30010];
//判断函数 
bool com(Student a,Student b){ 
	if(a.score!=b.score){
		return a.score>b.score;
	}else{
		return strcmp(a.id,b.id)<0;
	}
} 

int main(){
	//num记录总人数 
	int n,k,num=0;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&k);
		for(int j=0;j<k;j++){
			scanf("%s %d",&stu[num].id,&stu[num].score);
			stu[num].market=i; 
			num++;
		}
		//考场内排名 
		sort(stu+num-k,stu+num,com);
		stu[num-k].out_rank=1;
		for(int j=1+num-k;j<num;j++){
			if(stu[j].score==stu[j-1].score){//与上一位成绩相等 
				stu[j].out_rank=stu[j-1].out_rank;
			}else{//成绩不相等 
				stu[j].out_rank=j+1-(num-k); 
			}
		}	
	}
	//总排名 
	sort(stu,stu+num,com);
	stu[0].rank=1; 
	for(int i=1;i<num;i++){
		if(stu[i].score==stu[i-1].score){
			stu[i].rank=stu[i-1].rank;
		}else{
			stu[i].rank=i+1;
		}
	} 
	
	printf("%d\n",num);
	for(int i=0;i<num;i++){
		printf("%s %d %d %d\n",stu[i].id,stu[i].rank,stu[i].market,stu[i].out_rank); 
	
	}
	
	return 0;
} 

     

猜你喜欢

转载自blog.csdn.net/qq_40959340/article/details/81808490
今日推荐