PAT-A 1025. PAT Ranking (25)(25 分)分配局部和全局排名

https://pintia.cn/problem-sets/994805342720868352/problems/994805474338127872

1025 PAT Ranking (25)(25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
#include <iostream>
#include <cstdio>
#include <algorithm> 
#include <cstring>
using namespace std;
struct Student{
	char id[15];
	int score;
	int location;
	int local_rank;
}stu[10001];

bool cmp(Student a,Student b){
	if(a.score!=b.score){
		return a.score>b.score;
	}
	else{//a.score==b.score 
		return strcmp(a.id,b.id)<0;
	}
}
int main(int argc, char** argv) {
	int n;//num of locations 
	int k;//num of students
	cin>>n;
    int num=0;//记录每个考场的人数 
	for(int i=0;i<n;i++){
		cin>>k;
		for(int j=0;j<k;j++){
			scanf("%s %d",&stu[num].id,&stu[num].score);
			stu[num].location=i+1;
			num++;
		}
		sort(stu+num-k,stu+num,cmp);//给该考场内的k个学生排序 
		//开始分配局部排名
		stu[num-k].local_rank=1; 
		for(int j=num-k+1;j<num;j++){
			if(stu[j].score==stu[j-1].score){
				stu[j].local_rank=stu[j-1].local_rank;
			}else{
				stu[j].local_rank=j+1-(num-k);
			}
		}  
	}
	printf("%d\n",num);
	//开始分配全局排名 
	sort(stu,stu+num,cmp);
	int global_rank=1; 
	for(int i=0;i<num;i++){
		if((i>0)&&(stu[i].score!=stu[i-1].score)){
           global_rank=i+1;		
		}
	    printf("%s %d %d %d\n",stu[i].id,global_rank,stu[i].location,stu[i].local_rank);	
	} 


	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81475899