PAT A1025 PAT Ranking(25)[PAT排名,排序]

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank 

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

      
    

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意

学生分区排名和总排名

思路1

  1. 将不同区域的学生加到不同的 vector 中,更新本地排名
  2. 之后将更新过的学生加到一个全局数组中
  3. 再更新一遍全局排名

代码1

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

const int N = 110;

struct Student
{
    string id;
    int grade, location_number, local_rank, final_rank;
    bool operator< (const Student& t) const
    {
        if(grade != t.grade)
            return grade > t.grade;
        return id < t.id;
    }
};


vector<Student> grades[N];  // 分区成绩
vector<Student> all; // 总成绩


int main()
{
    int n, k;
    cin >> n;
    for(int i = 1; i <= n; i++)
    {
        cin >> k;
        for(int j = 0; j < k; j++)
        {
            string id;
            int grade;
            cin >> id >> grade;
            grades[i].push_back({id, grade, i});
        }
        sort(grades[i].begin(), grades[i].end());
        // 更新本地排名
        for(int j = 0; j < k; j++)
        {
            if(!j || grades[i][j].grade != grades[i][j-1].grade)
                grades[i][j].local_rank = j + 1;
            else
                grades[i][j].local_rank = grades[i][j-1].local_rank;
            
            all.push_back(grades[i][j]);
        }
    }
    sort(all.begin(), all.end());
    for(int i = 0; i < all.size(); i++)
    {
        
        if(!i || all[i].grade != all[i-1].grade)
            all[i].final_rank = i + 1;
        else
            all[i].final_rank = all[i-1].final_rank;
    }
    
    cout << all.size() << endl;
    for(int i = 0; i < all.size(); i++)
    {
        cout << all[i].id << " " << all[i].final_rank << " " << all[i].location_number << " " << all[i].local_rank << endl;
    }
    
    return 0;
}
发布了166 篇原创文章 · 获赞 27 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/HdUIprince/article/details/105475647