PTA(Basic Level)1042.字符统计

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
思路
  • isalpha判断是否为字母
  • transform(s.begin(),s.end(),s.begin(),::tolower);将字符都转换为小写
代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    getline(cin, s);
    transform(s.begin(),s.end(),s.begin(),::tolower);
    map<char,int> dict;
    map<char,int>::iterator it;
    for(int i=0;i<s.size();i++)
    {
        if(isalpha(s[i]))
        {
            it = dict.find(s[i]);
            if(it != dict.end())
                it->second += 1;
            else
                dict[s[i]] = 1;
        }
    }
    char maxchar;
    int maxvalue = -1;
    for(it=dict.begin();it!=dict.end();it++)
    {
        if(it->second > maxvalue)
        {
            maxvalue = it->second;
            maxchar = it->first;
        }
    }
    cout << maxchar << " " << maxvalue;
    return 0;
}
引用

https://pintia.cn/problem-sets/994805260223102976/problems/994805280817135616

猜你喜欢

转载自www.cnblogs.com/MartinLwx/p/11606349.html