1042. 字符统计(20)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
思路:统计所有字母的个数,循环找出最大值,注意:若并列输出字母序列小的字母,所以在存照最大项时注意用
num[i]>num[max_loc]
    max_loc=i;

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

void CountNum(char str[],int num[])         //统计字符中各个字母的个数
{

    int i,length;
    length=strlen(str);
    for(i=0;i<length;i++)
    {
        if(str[i]>='a'&& str[i]<='z')
            num[str[i]-'a']++;
        if(str[i]>='A'&& str[i]<='Z')
            num[str[i]-'A']++;

    }
}

int main()
{
    char str[1010];
    int num[30]={0};
    int i,max_loca=0;
    gets(str);
    CountNum(str,num);
    for(i=1;i<26;i++)
    {
        if(num[i]>num[max_loca])
            max_loca=i;

    }
    printf("%c %d",'a'+max_loca,num[max_loca]);
    return 0;
}




猜你喜欢

转载自blog.csdn.net/qq_36834256/article/details/79885873