HDU1503 Advanced Fruits【LCS】

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4957    Accepted Submission(s): 2633
Special Judge

 

Problem Description

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach
ananas banana
pear peach

Sample Output

appleach
bananas
pearch

Source

University of Ulm Local Contest 1999

问题链接:HDU1503 Advanced Fruits

问题描述:给定两个字符串S1和S2,求一个最短字符串S,使得S1和S2均是S的子序列

解题思路:最长公共子序列LCS,求出S1和S2的最长递增子序列,标记这个最长公共子序列在两个字符串中的位置,然后打印。最短就要使得最长递增子序列只输出一次,可以选择只输出S1中的这个子序列,跳过S2中的子序列,这样就输出一次。具体看程序。

AC的C++程序:

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>

using namespace std;

const int N=205;
int dp[N][N];
bool vis[2][N];

void LCS(string a,string b)
{
	memset(dp,0,sizeof(dp));
	memset(vis,false,sizeof(vis));
	for(int i=1;i<=a.length();i++)
	  for(int j=1;j<=b.length();j++)
	    if(a[i-1]==b[j-1])
	      dp[i][j]=dp[i-1][j-1]+1;
	    else
	      dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
   //标记最长公共子序列在两个字符串中的位置
	int i=a.length(),j=b.length();
	while(i&&j)
	{
		if(dp[i][j]==dp[i-1][j-1]+1&&a[i-1]==b[j-1])
		{
			vis[0][i-1]=vis[1][j-1]=true;
			i--,j--;
		}  
		else if(dp[i-1][j]>dp[i][j-1])
		  i--;
		else
		  j--;	
	}
	   
}

int main()
{
	string a,b;
	while(cin>>a>>b)
	{
		LCS(a,b);
        //进行打印
		int i=0,j=0;
		while(i<a.length()||j<b.length())
		{
			for(;i<a.length()&&!vis[0][i];i++)
			  printf("%c",a[i]);
			for(;j<b.length()&&!vis[1][j];j++)
			  printf("%c",b[j]);
			printf("%c",a[i]);
			i++;
			j++;
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83894152