[POJ2739]Sum of Consecutive Prime Numbers

Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22692   Accepted: 12404

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source


题目地址:http://poj.org/problem?id=2739

题解:用连续素数和表示一个数 问有多少种表示方法 直接暴力。。。

AC代码:

#include <cstdio>
const int maxn = 2000;
int prime[maxn];
bool mark;
int cnt;
int n;

void getPrime();                //素数打表

int main() {
    getPrime();
    while (scanf("%d", &n)!=EOF && n) {
        int ans = 0;
        for (int i = 0; prime[i] <= n; ++i) {   
            int sum = 0;
            for (int j = i; j < cnt; ++j) {
                sum += prime[j];
                if (sum == n) {                 //连续素数和等于n ans+1
                    ++ ans;
                    break;
                }
                else if (sum > n) {             //连续素数和大于n 跳出当前循环 
                    break;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

void getPrime() {
    prime[0] = 2;
    prime[1] = 3;
    bool mark;
    cnt = 2;
    for(int i = 4; i < 10010; ++i) {
        mark = true;
        for (int j = 2; j * j <= i; ++j) {
            if (i % j == 0) {
                mark = false;
            }
        }
        if (mark) {
            prime[cnt++] = i;
        }
    }
}


猜你喜欢

转载自blog.csdn.net/u012431590/article/details/51400767