poj2739Sum of Consecutive Prime Numbers(尺取法)

Language:Default

Sum of Consecutive Prime Numbers

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29363   Accepted: 15727

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

Japan 2005

尺取法 +素数筛选

#include<iostream>
#include<cstdio>
#include<string.h>
#define MAX 10000
bool prime[MAX+1];
int primes[MAX+1];
void Prime()
{
	int i,j,count=0;
	memset(prime,true,sizeof(prime));
	prime[0]=prime[1]=false;
	prime[2]=true;
	
	for(i=2;i*i<=MAX;i++)
	{
		if(prime[i])
		{
			for(j=i+i;j<=MAX;j+=i)
			{
				prime[j]=false;
			}
		}
	}
}
void getPrimes()
{
	int k=1;
	for(int i=2;i<MAX;i++)
	{
		
		if(prime[i])
		{
			primes[k++]=i;
		}
	}
	
	
	
}
int main()
{
	Prime();
	getPrimes();
	int i,j,count=0;
	int num;
	while(scanf("%d",&num)!=EOF&&(num!=0))
	{
		int left=1,right=1,cnt=0;
	    while(left<=num)
	    {
	    	int sum=0;
	    	for(int right=left;right<=num;right++)
	    	{
	    		sum+=primes[right];
	    		if(sum==num)
	    		{
	    			cnt++;
	    			break;
				}
			}
			if(sum<num)
			 break;
			left++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42173193/article/details/86744073