POJ-2739 Sum of Consecutive Prime Numbers

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

题解:

素数打表后,双重循环,从1往后选择第一个相加的数,如果可以组成一串数,相加和为要求整数则ans+1;

CODE

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <stack>
#include <deque>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <queue>
#include <functional>
#include <time.h>
using namespace std;
typedef long long LL;
#define MAXN 10010
int vis[10010];
void f()
{
    int m=sqrt(MAXN+0.5);
    memset(vis,0,sizeof(vis));
    for(int i=0; i<2; i++)
        vis[i]=1;
    for(int i=2; i<=m; i++)
        if(!vis[i])
            for(int j=i*i; j<=MAXN; j+=i)
                vis[j]=1;
}
int main()
{
    f();
    int ans = 0,n,sum;
    while(cin >> n && n!=0)
    {
        ans=0;
        for(int i=2; i<=n; i++)
        {
            sum=0;
            if(vis[i]==1)
                continue;
            for(int j=i; j<=n; j++)
            {
                if(vis[j]==0)
                    sum+=j;
                if(sum == n)
                {
                    ans++;
                    break;
                }
                if(sum > n)
                    break;
            }
        }
        cout << ans << endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/AC__GO/article/details/81177814