[POJ1083]Moving Tables

Moving Tables
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 29714   Accepted: 9880

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source


题目地址:http://poj.org/problem?id=1083

题解:题意大概就是每十分钟走廊某一点只能同时经过一次搬桌子 然后计算一下重复就好了 最多需要多久时间

覆盖区间最大值基本上就是

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 210;
int path[maxn];

int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        int n;
        scanf("%d", &n);
        memset(path, 0, sizeof(path));      //因为多组数据所以每组都要初始化
        int s, t;
        while(n--) {
            scanf("%d%d", &s, &t);
            if(s > t) {                     //保证s《= t
                swap(s, t);
            }
            s = (s + 1) / 2;                //房间号变成房间从走廊左边开始计数的第几个
            t = (t + 1) / 2;
            for(int i = s; i <= t; ++i) {
                ++ path[i];                 //每个点需要被经过多少次
            }
        }

        int ans = 0;
        for(int i = 0; i < maxn; ++i) {
            ans = max(ans, path[i]);        //取出区间覆盖最大值最为答案
        }
        printf("%d\n", ans * 10);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u012431590/article/details/51418249
今日推荐