POJ 1083 Moving Tables 贪心

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

 一开始想着按照结束时间从小到大, 开始时间从大到小排序, 结果wa, 从网上找出一组数据, 结果发现确实是错误的。

正确的贪心应该是从开始时间从小到大的顺序, 结束时间从小到大的顺序排。 。。

拍完之后就是依次遍历, 直到所有的指令都执行完。

哦,对,当输入的起点为偶数时需要减1,终点为奇数时,需要+1,当起点大于终点的时候需要交换一下。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=205;
int t;
int n;
struct node
{
    int s,e;
}a[maxn];
int vis[maxn];
int compare (node a,node b)
{
    if(a.s<b.s)
    {
        return 1;
    }
    else if(a.e==b.e)
    {
        if(a.e<b.e)
        {
            return 1;
        }
        else
        {
            return 0;
        }
    }
    else
    {
        return 0;
    }
}
int main()
{
    scanf("%d",&t);
    while (t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for (int i=0;i<n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(x%2==0)
                x--;
            if(y%2)
                y++;
            if(x>y)
                swap(x,y);
            a[i].s=x;
            a[i].e=y;
        }
        sort (a,a+n,compare);
        int num=0,ans=0;
        while (num<n)
        {
            int e=-0x3f3f3f3f;
            for (int i=0;i<n;i++)
            {
                if(!vis[i]&&a[i].s>e)
                {
                    num++;
                    vis[i]=1;
                    e=a[i].e;
                }
            }
            ans++;
        }
        printf("%d\n",ans*10);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83868578