Moving Tables(POJ-1083)

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

在这里插入图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
在这里插入图片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
题意分析:有四百个房间,编号为1到400,偶数号房间与奇数号房间分别分布在一条走廊的两侧,现在要搬一些桌子,走廊最多只能容下一张桌子的宽度,因此一旦有冲突搬桌子完成的时间就会多10分钟,普通的没有冲突时就只需10分钟,问最后搬子需要多长时间,也就是求会发生几次冲突。
解题思路:将每相对的两个房间的那段中走廊分别编号,做标记,计算搬完桌子后每段走廊走的最多的次数即可。
AC代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
	int n,i,T,x,y,max,t,book[500];
	scanf("%d",&T);
	while(T--)
	{
		max=1;
		scanf("%d",&n);
		memset(book,0,sizeof(book));
		while(n--)
		{
			scanf("%d%d",&x,&y);
			//这里举个例子就懂了,例如1和2号房间中间的那段走廊编号就为0
			//此时记录的就是0这段走廊的使用次数
			x=(x-1)/2;
			y=(y-1)/2;
			if(x>y)
			{
				t=x;
				x=y;
				y=t;
			}
			for(i=x;i<=y;i++)
				book[i]++;
		}
		for(i=0;i<=200;i++) //四百个房间分为两百段走廊,统计出所有走廊使用次数最多的次数即可
			if(book[i]>max)
				max=book[i];
		printf("%d\n",max*10);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_44313771/article/details/104525063
今日推荐