HDU——1050 Moving Tables(贪心算法)

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
这里写图片描述

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
这里写图片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output

10
20
30

解题思路:


相对门的两个房间占用同一处走廊,所以例如有1——3和4——6移动方式时,它们是共享了同一段走廊的,即3号房间门前的走廊。

分析过程有如下图所示:
这里写图片描述

上述分析过程转自 转自:(转自https://blog.csdn.net/code_pang/article/details/8251240


看了图片分析之后,就很容易想出解题方法了。
1.将走廊根据房间分成200个小段 , 例如 1 、 2 号房间就对应着第一段走廊,3、4号房间对应第二段走廊·········。
2.本题代码中定义了一个map数组,用来记录每段走廊被占用的次数,寻找被占用次数最多的那段走廊,则最后需要的时间就是这段走廊被占用的次数max * 10。

代码:

#include <cstdio>
#include <cstring>
using namespace std;


typedef struct{
    int s;
    int t;
}Movement;

int minvalue(int a , int b){
    if(a < b)
        return a;
    return b;
}

int maxvalue(int a , int b){
    if(a > b)
        return a;
    return b;
}

Movement mov[210];

int map[210];
int main(){
    freopen("D://testData//1050.txt" , "r" , stdin);
    int t , n , i , j , max;
    scanf("%d",&t);
    while(t --){
        memset(map , 0 , sizeof(map));
        scanf("%d",&n);
        max = 0;
        for(i = 0 ; i < n ; i ++){
            scanf("%d %d",&mov[i].s , &mov[i].t);
        }

        for(i = 0 ; i < n ; i ++){

            //计算这次移动会占据哪一段路 , 因为肯能是从左向右移动 , 也有可能从右向左移动 ,这里统一看成左-->右
            int temp1 = (minvalue(mov[i].s , mov[i].t) + 1 )/ 2;
            int temp2 = (maxvalue(mov[i].s , mov[i].t) + 1 )/ 2;

            for(j = temp1 ; j <= temp2 ; j ++){
                map[j] = map[j] ++;
                if(map[j] > max)
                    max = map[j];
            }
        }

        printf("%d\n",10*max);
    }
}

猜你喜欢

转载自blog.csdn.net/sinat_38052999/article/details/80144869
今日推荐