HDU1050-Moving Tables

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
在这里插入图片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30

分析:

题意:
一层楼 400个房间,编号从1到400,分成两行,奇数一行,偶数一行,一条走廊在两排房间的中间,现在要从一共房间往另外一共房间搬桌子,由于走廊太窄,一次只能通过一张桌子,所以有重叠走廊段的桌子不能在同一个回合搬,问你搬完全部桌子,需要多少分钟?每个回合10分钟。

解析:
房间门口每10分钟只能通过一张桌子,所以所以两张桌子在不通过同一房间门口是可以同时移动的,所以我们只要求得房间门口通过的次数的最大值即可!

代码:

#include<iostream>
#include<cstdio>
#define N 205

using namespace std;

int book[N];

int main()
{
	int T,n,x,y,Max;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			if(x>y)
				swap(x,y);
			x=(x+1)/2;
			y=(y+1)/2;
			for(int i=x;i<=y;i++)
			{
				book[i]++;
			}
		}
		Max=0;
		for(int i=1;i<=200;i++)
		{
			if(book[i]>Max)
				Max=book[i];
			book[i]=0;
		}
		printf("%d\n",Max*10);
	}
	return 0;
}
发布了46 篇原创文章 · 获赞 16 · 访问量 404

猜你喜欢

转载自blog.csdn.net/weixin_43357583/article/details/105106947
今日推荐