HDU-1050-Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40960    Accepted Submission(s): 13461


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
 
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
 
  
10 20 30
 

题目大意:一共有400个房间,现在搬桌子,一个过道只能通过一张桌子,每次搬都要10分钟,而且在一个区域内,不能将这个区域内的任何房间的桌子搬动,例如:将桌子从10搬到40,在10-40这个区间不能搬其他桌子,然后让你写个程序计算出搬动桌子需要的最短时间;

思路:就是统计在这个区间内区间出现次数最多的那个

代码:

#include<map>
#include<stack>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1100
#define ll long long
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        int n,i,j,a,b,ans=1;
        int max1[maxn];
        memset(max1,0,sizeof(max1));
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&a,&b);
            int l=min(a,b);
            int r=max(a,b);
            l=(l+1)/2;
            r=(r+1)/2;
            for(j=l; j<=r; j++)
                max1[j]++;
        }
        sort(max1,max1+400,cmp);
        printf("%d\n",max1[0]*10);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81018978
今日推荐