poj1064

Cable master
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 77090   Accepted: 15630

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

一句话题意:
给定n条长度不一的线段,问是否能均分成k段,如果不能则输出0.00.(1 = N = 10000,1 = K = 10000,每条线段的长度大于等于1,小于等于100km)
解析:
这种题目,没有明显的规律,只能尝试分段,比较快的解决方式就是二分。
由于题目不能划分K段则输出0.00,所以L=0.00,R=100*1000或者读入的最大值
读入的最大值需要比较n次得出,不如R直接取最大值,这样最多的比较次数为log(100000)<20,也就是说最多比较也没有20次。
程序:整数二分
#include<iostream>
#include<cstdio>
using namespace std;
int n,k;
const int maxn=10010;
int a[maxn];
int check(int  x){
    int s=0;
    for(int i=1;i<=n;i++)
        s=s+a[i]/x;
    if (s>=k)return 1;
    else return 0;
}
int main(){
    cin>>n>>k;
    double x;
    int temp0;
    for(int i=1;i<=n;i++){
        cin>>x;
        a[i]=x*100;
    }
    int l=0,r=10000000,mid;
    while (l<r){
        mid=(l+r+1)/2;
        if(check(mid))l=mid;
        else r=mid-1;
    }
    printf("%.2lf\n",l/100.0);
    return 0;
}
    

猜你喜欢

转载自www.cnblogs.com/ssfzmfy/p/10921795.html
今日推荐