Cable master poj1064

版权声明:转载请带一下我这个小蒟蒻哦~ https://blog.csdn.net/QLU_minoz/article/details/89135283

 Cable master 

http://poj.org/problem?id=1064

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

题意:

把n根木棒分成等长的m份,长度精确到cm,问可以切下的最大长度是多少

这个题被精度坑惨惹(哭唧唧QWQ),wa题一时爽,一直wa一直爽,交了5发都没过,最后放弃辽(貌似看到 lk小朋友wa了10发,心理素质也太强辣!)

大体思路就是二分找可以分成的最大长度,看是否可以分成至少m块,而问题就在于精度处理!这里不能使用( r - l > exp)了,会因为精度问题出不来,改为循环100次,又因为如果直接用%.2f输出的话,四舍五入又是一个问题,所有就直接*100,再/100,就没有精度问题了,

嘤嘤嘤(╥╯^╰╥),是我真的没有想到!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define ll long long
#define INF 0x3f3f3f3f
#define exp 1e-8
const int maxn=1e6+5;
double a[maxn];
int n,m;

bool check(double x)//可以分成多少块
{
    int Count=0;
    for(int i=0;i<n;i++)
        Count += (int)(a[i]/x);
    return Count>=m;
}

int main()
{
    scanf("%d%d",&n,&m);
    double Max=0;
    double sum=0;
    for(int i=0;i<n;i++)
    {
        scanf("%lf",&a[i]);
        sum+=a[i];
        Max=max(Max,a[i]);
    }
    double l=0,r=Max,mid;
    for(int i=1;i<=100;i++)//注意精度问题!
    {
        mid=(r-l)/2+l;
        if(check(mid))
            l=mid;
        else
            r=mid;
        cout<<l<<" "<<r<<endl;
    }
    printf("%.2f\n",(int)(l*100)/100.0);// l*100/100
}

猜你喜欢

转载自blog.csdn.net/QLU_minoz/article/details/89135283