POJ1064 Cable master(二分法)

题目链接

Cable master

Time Limit: 1000MS   Memory Limit: 10000K

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

有N条绳索,他们的长度分别为Li。如果从它们中切割出K条长度相同的绳索的话,这K条绳索每条最长能有多少米?答案保留到小数点后两位。

这道题用二分搜索可以容易的求得答案。

二分搜索法的结束判定:(来自《挑战程序设计竞赛第二版》)

在输出小数的问题中,一般都会制定允许的误差范围或者是指定输出中小数点后面的位数。因此在使用二分搜索法时,有必要设置合理的结束条件来满足精度的要求。在下面的程序中,我们指定了循环次数作为终止条件。1次循环可以把区间的范围缩小一半,100次的循环则可以达到10^{-30}的精度范围,基本上是没有问题的。除此之外,也可以把终止条件设为像(ub-lb)>EPS这样,指定一个区间的大小。在这种情况下,如果EPS取得太小了,就有可能会因为浮点小数精度的原因导致陷入死循环,请千万小心。


AC代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<vector>
#include<cmath>
#include<stack>
using namespace std;
vector<double> cable;
int N,K;
bool islegal(double x)//切割成长度为x的绳索时是否满足条件 
{
	int num=0;
	for(int i=0;i<cable.size();i++)
	num+=int(cable[i]/x);
	return num>=K;
}
int main()
{
	cin>>N>>K;
	double len;
	while(cin>>len) cable.push_back(len);
	
	double lb=0,ub=1<<30;//初始化边界条件 
        for(int i=0;i<100;i++)
        {
    	    double mid=(lb+ub)/2;
    	    if(islegal(mid)) lb=mid;
    	    else ub=mid;
	}
	double ans=floor(ub*100)/100;//小数点后两位 
	cout<<setiosflags(ios::fixed)<<setprecision(2)<<ans;
}

猜你喜欢

转载自blog.csdn.net/qq_40889820/article/details/81782599
今日推荐