POJ 3020:Antenna Placement(无向二分图的最小路径覆盖)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6334   Accepted: 3125

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
 
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5


好吧。

做了几道简单的匈牙利算法和简单的最小覆盖。。最终遇到一道纠结的题了。。

这题目我看了小优酱的题意解析(Orz) 点击打开链接 小优酱写解题报告真的非常具体。。

从他(她)那里我学到了非常多东西。。在此十分感谢。。尽管他(她)都不知道我。。(233)


无向二分图的最小路径覆盖 = 顶点数 – 最大二分匹配数/2



 #include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int dx[]= {-1,1,0,0};
int dy[]= {0,0,-1,1};

int t, m, n; //输入数据 
int link[M];   //用于推断是否为饱和点。
int city[M][M]; //用于记录城市
int v1, v2;     //拆分后建立的图
int sum;        //城市的总数
bool MAP[M][M];   //建立后的图
bool cover[M];   //用于查看是否为覆盖点
int ans;         //最大分配值    
char str;       //用于输入字符串

bool dfs(int x)     //匈牙利算法
{
    for(int y=1; y<=v2; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(!link[y] || dfs( link[y] ))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    scanf("%d", &t);
    while( t-- )
    {
        memset(city, 0, sizeof(city));
        memset(link, 0, sizeof(link));
        memset(MAP, false, sizeof(MAP));
        ans=0;
        v1=0;
        v2=0;
        sum=0;
        scanf("%d%d", &n, &m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                cin>>str;
                if(str=='*')
                {
                    city[i][j]=++sum;
                }
            }
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                if(city[i][j])
                    for(int k=0; k<4; k++)
                        if(city[ i + dx[k]][j + dy[k]])
                            MAP[ city[i][j] ] [ city[i + dx[k]] [ j + dy[k]] ] = true;   
        v1=v2=sum;
        for(int i=1; i<=v1; i++)
        {
            memset(cover, false, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("%d\n", sum-ans/2);  //无向二分图:最小路径覆盖数 = "拆点"前原图的顶点数 - 最大匹配数/2  
    }

    return 0;
}


猜你喜欢

转载自www.cnblogs.com/ldxsuanfa/p/10888638.html
今日推荐