POJ1050-To the Max

版权声明:禁止盗用 https://blog.csdn.net/weixin_43411988/article/details/89199394

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.
Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2
Sample Output

15
Source

Greater New York 2001

#include <iostream>
#include <cstring>
using namespace std;

int dp[105][105];
int n, Max;
int buf[105];

int getmax() {
	int temp[105], max = n * (-127);
	memset(temp, 0 , sizeof(temp));
	for (int i = 1; i <= n; i++) {
		temp[i] = temp[i - 1] > 0 ? temp[i - 1] + buf[i] : buf[i];
		if (max < temp[i])
			max = temp[i];
	}
	return max;
}

void read() {
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++)
			cin >> dp[i][j];
	}
}

int solve() {
	Max = (-127) * n;
	for (int i = 0; i < n; i++) {
		for (int j = i; j < n; j++) {
			memset(buf, 0 , sizeof(buf));
			for (int k = 0; k < n; k++)
				for (int l = i; l <= j; l++)
					buf[k] += dp[k][l];
			int d = getmax();
			if (d > Max)
				Max = d;
		}
	}
	return Max;
}

int main() {
	while (cin >> n) {
		read();
		solve();
		cout << Max << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43411988/article/details/89199394