POJ-1050 To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 56579   Accepted: 29921

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

OJ-ID:
poj-1050

author:
Caution_X

date of submission:
20191117

tags:
二维数组前缀和

description modelling:
计算二维数组权值和最大的子矩阵

major steps to solve it:
枚举i(i∈[1,n])到j(j∈[i+1,n])行的各列元素之和的一维数组,计算该一维数组连续区间的权值最大和并更新答案

warnings:
将二维数组化成一维数组来处理,减少时间开销

AC code:

#include <stdio.h>
#define MAXSIZE 101

//求出一行中最大的子段和
int MaxArray( int n, int arr_[])
{
    int i, sum_ = 0, max_ = 0;
    for (i=1; i<=n; i++)
    {
        if (sum_>0)
        {
            sum_ += arr_[i];
        }
        else
        {
            sum_ = arr_[i];
        }
        if (sum_>max_)
        {
            max_ = sum_;
        }
    }
    return max_;
}
//求出最大子矩阵和。
int MaxMatrix( int n, int arr_[][MAXSIZE])
{
    int max_ = arr_[1][1];
    int sum_;
    int i, j, k;
    int temp_arr[MAXSIZE]; 
    for (i=1; i<=n; i++) //从第一行开始,直到第n行
    {
        for (j=1; j<=n; j++) //只有起始行改变,temp_arr数组才初始化
        {
            temp_arr[j] = 0;
        }        
        for (j=i; j<=n; j++) //从i行到第n行
        {
            for (k=1; k<=n; k++)  
            {
                temp_arr[k] += arr_[j][k]; //temp_arr[k] 表示从第i行到第n行中第k列的总和。
            }         
            sum_ = MaxArray(n, temp_arr); //求出该行中最大的子段和       
            if (sum_ > max_)
            {
                max_ = sum_;
            }
        }
    }
    return max_;
}
int main()
{
    int n;
    int i, j;
    int arr_[MAXSIZE][MAXSIZE];
    int max_;
    while (~scanf("%d", &n)) //多组测试。 相当于 scanf("%d", &n) != EOF
    {
        for (i=1; i<=n; i++)
        {
            for (j=1; j<=n; j++)
            {
                scanf("%d", &arr_[i][j]);
            }
        }
        max_ = MaxMatrix(n, arr_);
        printf("%d\n", max_);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/cautx/p/11879089.html