POJ 1050 To the Max(动态规划)

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

看网上题解才恍然大悟,根据最长递增子序列的思想, 将二维的数组看成为一维的形式进行求解。

设一个三维数组dp[i][j][k],i表示行,j表示起始列,k表示终止列。

则dp[i][j][k]=max(dp[i-1][j][k]+sum,sum).其中sum表示的是第i行从j到k的和。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=105;
int n;
int dp[maxn][maxn][maxn];
int a[maxn][maxn];
int ans=-0x3f3f3f3f;
int main()
{
    scanf("%d",&n);
    memset (dp,0,sizeof(dp));
    for (int i=1;i<=n;i++)
    {
        for (int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for (int i=1;i<=n;i++)
    {
        for (int j=1;j<=n;j++)
        {
            int sum=0;
            for (int k=j;k<=n;k++)
            {
                sum+=a[i][k];
                dp[i][j][k]=max(dp[i-1][j][k]+sum,sum);
                ans=max(dp[i][j][k],ans);
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83855903
今日推荐