POJ-1050-To the Max

To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 51510   Accepted: 27244

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
using namespace std;
int a[105][105],sum[105],temp[105];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int ans=-10000000;
		for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
		cin>>a[i][j];
		for(int i=0;i<n;i++)
		{
			for(int j=i;j<n;j++)
			{
				memset(temp,0,sizeof(temp));
				for(int k=0;k<=n;k++)
					for(int l=i;l<=j;l++)
					 	temp[k]+=a[l][k];
				memset(sum,0,sizeof(sum));
				sum[0]=temp[0];
				for(int c=1;c<n;c++)
				{
					sum[c]=(sum[c-1]>0?sum[c-1]:0)+temp[c];
					ans=max(ans,sum[c]);
				}
			}
		}
		cout<<ans<<endl;
	}
}



import java.util.*;
import java.lang.*;
public class Main
{
	static public void main(String []args)
	{
		Scanner cin=new Scanner(System.in);
		int n;
		int [][]a;
		int []temp;
		int []sum;
		while(cin.hasNext())
		{
			int ans=-1000000;
			n=cin.nextInt();
			a=new int[n][n];
			temp=new int[n];
			sum=new int[n];
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++)
					a[i][j]=cin.nextInt();
			for(int i=0;i<n;i++)
			{
				for(int j=i;j<n;j++)
				{
					Arrays.fill(temp,0);
					for(int k=0;k<n;k++)
						for(int l=i;l<=j;l++)
							temp[k]+=a[l][k];
					Arrays.fill(sum,0);
					sum[0]=temp[0];
					for(int c=1;c<n;c++)
					{
						sum[c]=(sum[c-1]>0?sum[c-1]:0)+temp[c];
						ans=Math.max(ans,sum[c]);
					}
				}
			}
			System.out.println(ans);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/xiaoyao_zhang/article/details/80300687