LightOJ - 1005 Rooks (找规律)

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are not. R2 and R3 are also in non-attacking positions.
在这里插入图片描述
Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.
Input
Input starts with an integer T (≤ 350), denoting the number of test cases.
Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).
Output
For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.
Sample Input
8
1 1
2 1
3 1
4 1
4 2
4 3
4 4
4 5

Sample Output
Case 1: 1
Case 2: 4
Case 3: 9
Case 4: 16
Case 5: 72
Case 6: 96
Case 7: 24
Case 8: 0
问题链接: https://cn.vjudge.net/problem/LightOJ-1005
问题简述: 有一个 x×x 的棋盘,在上面放个Rook,使任意两个Rook之间不存在冲突,问有多少种摆放方案。
问题分析: 找数学规律可得可行数量是C(n,m)×A(n,m),最后化简得出的是((n)×(n-1)×…×(m))^2/n!
先算出(n)×(n-1)×…×(m),逐个除与1,2,…,n,否则会超long long。再乘与一个(n)×(n-1)×…×(m)
(md他案例:后面还有一个空格,以至于一直WA找不出错误,我佛拉)
AC通过的C++语言程序如下:

#include <map>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <climits>
#include <queue>
#include <iomanip>
#include <vector>
#define ll long long
#include <stdio.h>
using namespace std;

int main()
{
    //ios::sync_with_stdio(false);
    ll n;
    scanf("%lld",&n);
    for(ll j=1;j<=n;j++)
    {
        ll a,b;
        scanf("%lld%lld",&a,&b);
        printf("Case %d: ",j);
        ll sum=1;
        for(ll i=a;i>a-b;i--)
            sum*=i;
        for(ll i=1;i<=b;i++)
            sum/=i;
        for(ll i=a;i>a-b;i--)
            sum*=i;
        printf("%lld\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44012745/article/details/88937557
今日推荐