LightOJ 1138 Trailing Zeroes【二分+阶乘规律】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/86586751

题目:

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题目大意:

        给定一个数 k ,求解一个数,该数的阶乘 的末尾刚好有 k 个0。

解题思路:

        这题有很熟悉的感jio,上来就用的递推,然后就一直TL,原来是二分,原来是二分,二分真是个神奇的算法。。

实现代码:

#include<cstdio>
#define inf 0x3f3f3f3f
#define ll long long
int judge(ll n){			//求n的阶乘从末位开始连续0的个数
	ll ans=0;
	while(n){
		ans += n/5;
		n /= 5;
	}
	return ans;
}

int main(){
	ll t,k=0;
	scanf("%lld",&t);
	while(t--){
        ll q;
		scanf("%lld",&q);
		printf("Case %lld: ",++k);

		ll l=0,r=inf,mid;
		while(l <= r){
			mid = (l + r)/2;
			if(judge(mid) >= q)		//0的个数大于q减小区间,找出最小的n{
				r = mid-1;
			else
                l = mid+1;
		 }
		 if(judge(l) == q)
		 	printf("%lld\n",l);
		 else
		 	printf("impossible\n");
	}
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/86586751