算法笔记6120ProblemD String Subtraction

题目描述

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S1 - S2 in one line.

样例输入

They are students.
aeiou

样例输出

Thy r stdnts.

代码展示

#include<cstdio>
#include<cstring>
int main() {
    char str[10001];
    gets(str);
    char rep[10001];
    gets(rep);
    bool judge[100] = {false};

    for(int i = 0; i < strlen(rep); i++) {
        judge[rep[i] - ' '] = true;
    }


    for(int i = 0; i < strlen(str); i++) {
        if(judge[str[i] - ' '] == false)
            printf("%c", str[i]);
    }
    printf("\n");
    return 0;
}

小结

题目不难,还是用的散列的思想,这里我采用一个布尔型数组来记录每个字符是否需要进行替换。
需要注意的是:rep[i]减去的应该是第一个ASCII可显示字符,即空格,而不是’A’。

猜你喜欢

转载自blog.csdn.net/luminouswithyou/article/details/89196166