PAT:A1050 String Subtraction

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/81902885

PAT:A1050 String Subtraction 

Given two strings S~1~ and S~2~, S = S~1~ - S~2~ is defined to be the remaining string after taking all the characters in S~2~ from S~1~. Your task is simply to calculate S~1~ - S~2~ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S~1~ and S~2~, respectively. The string lengths of both strings are no more than 10^4^. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S~1~ - S~2~ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

const int maxn = 10010;
int main() {
	char str1[maxn], str2[maxn], c1, c2;
	cin.getline(str1, maxn);
	cin.getline(str2, maxn);
	int len1 = strlen(str1);
	int len2 = strlen(str2);
	bool isFlag = true;
	for(int i = 0; i < len1; i++) {
		isFlag = true;
		c1 = str1[i];
		for(int j = 0; j < len2; j++) {
			c2 = str2[j];
			if(c1 == c2) {
				isFlag = false;
				break;
			}
		}
		if(isFlag == true) {
			printf("%c", c1);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/81902885