PAT-1050 String Subtraction

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/81988983

1050 String Subtraction(20 分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

注意OJ上读取一行最方便的方法cin.getline(char* ,maxSize)

#include<stdio.h>
#include<iostream>
using namespace std;

char c1[10005];
char c2[10005];

int main(){

	cin.getline(c1,10002);
	cin.getline(c2,10002);

	for(int i=0;c1[i]!='\0';i++){
		bool ok=true;
		for(int j=0;c2[j]!='\0';j++){
			if(c2[j]==c1[i]){
				ok=false;break;
			}
		}
		if(ok)printf("%c",c1[i]);
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/81988983