《算法笔记》4.2小节——算法初步->哈希 问题 D: String Subtraction

版权声明:copyright©CodeIover reserved https://blog.csdn.net/qq_40073459/article/details/86625142

                                      问题 D: String Subtraction

题目描述

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S1 - S2 in one line.

样例输入

They are students.
aeiou

样例输出

Thy r stdnts.

实现代码:

#include<stdio.h>
#include<string.h>
#include<stdbool.h>
#define maxn 10001
char str1[maxn],str2[maxn];
bool hashTable[128];
int main()
{
	gets(str1);
	gets(str2);
	int len1=strlen(str1);
	int len2=strlen(str2);
	for(int i=0;i<len2;i++)
	{
		hashTable[str2[i]]=true;
	}
	for(int i=0;i<len1;i++)
    {
     	if(hashTable[str1[i]]==false){
     		printf("%c",str1[i]);
		 }
	}
	return 0;
}

 

结果如下:

猜你喜欢

转载自blog.csdn.net/qq_40073459/article/details/86625142