【PAT】A1050. String Subtraction (20)

Description:
Given two strings S1 and S2, S = S1 – S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 – S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 10^4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:
For each test case, print S1 – S2 in one line.

Sample Input:
They are students.

aeiou


Sample Output:
Thy r stdnts.
//NKW 甲级真题1039
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
const int maxn = 10010;
char s1[maxn], s2[maxn];
int hash[128];
int main(){
	memset(hash, 0, sizeof(hash));
	fgets(s1, maxn, stdin);
	if (s1[strlen(s1) - 1] == '\n')
		s1[strlen(s1) - 1] = '\0';
	fgets(s2, maxn, stdin);
	if (s1[strlen(s2) - 1] == '\n')
		s1[strlen(s2) - 1] = '\0';
	for (int i = 0; i < strlen(s2); i++)
		hash[s2[i]] = 1;
	for (int i = 0; i < strlen(s1); i++)
		if (hash[s1[i]] == 0)
			printf("%c", s1[i]);
	printf("\n");
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80949589