C/C++[codeup 6120]String Subtraction

问题 D:

6120 String Subtraction (20)

题目描述
Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.
输入
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
输出
For each test case, print S1 - S2 in one line.
样例输入
They are students.
aeiou
样例输出
Thy r stdnts.

#include <iostream>
#include <cstring>
using namespace std;
int main() {
    int hashtable[256] = {0};
    char str[10000];
    gets(str);
    while (1) {
        char c = getchar();
        if (c == '\n') break;
        hashtable[c] = 1;
    }
    for (int i = 0; i < strlen(str); i++) {
        if (hashtable[str[i]] == 0) cout << str[i];
    }cout<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u014281392/article/details/80849095
今日推荐