D-city--逆序并查集

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5911    Accepted Submission(s): 2064


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 
Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 
Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4
 
Sample Output
1
1
1
2
2
2
2
3
4
5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 
 
思路:题目需要逆向思考(正向行不通的时候,我们不防换一条路 试试)

我们可以逆向认为所有的点全是独立的,因为正
向的时候去掉其中某条边的,独立的点不一定会增多(去掉这条边后还有
其他边间接的相连),所以当我们逆向思考的时候,只会在增加某一条边
时减少独立的点(也就是联通的点增多),这样只会在他之后才会有可能
有某条边的操作是“无效”的(联通的点不变);

#include<iostream>
#include<string.h>
#include<math.h>
#define ll long long
using namespace std;
ll a[100005], b[100005], c[100005], p[10005];
ll n, m;
void init()
{
    for (int i = 0; i < n; i++)
        p[i] = i;
}
ll find(ll x)
{
    if (x == p[x])
        return x;
    else
        return p[x] = find(p[x]);
}
int main()
{
    while (scanf("%lld%lld", &n, &m) == 2)
    {
        init();
        for (int i = 1; i <= m; i++)
        {
            scanf("%lld%lld", &a[i], &b[i]);
        }
        c[m] = n;//m个元素之间都没有连接,此时分成n个集合
        for (int i = m; i > 1; i--)//m!=0,所以i!=1
        {
            ll tx, ty;
            tx = find(a[i]);
            ty = find(b[i]);
            if (tx == ty)
                c[i - 1] = c[i];
            else
            {
                c[i - 1] = c[i] - 1;
                p[tx] = ty;
            }
        }
        for (int i = 1; i <= m; i++)
        {
            printf("%lld\n", c[i]);
        }
    }
    system("pause");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/10719924.html