POJ3280—区间DP(变成回文串)

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).

FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800
Sample Output

900

这道题就是把给定的一段字符串换为回文字符串(通过对原有字符串进行增删两种操作进行),但是对于每种字符的增或删的费用都是不同的,我们要求的就是将该段字符串改成回文串所需的最小费用。
(n个字符,字符串长度为m)。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define M 2010
#define Min(a,b) (a>b?b:a)                          //比较大小
int cost[26];                                         //很巧妙的地方,对于某个字符进行增或删,只需保留较小的操作花费即可
char str[M];
int dp[M][M];
int main()
{
	int n,m,i,j;
	char ch[2];
	while(~scanf("%d%d",&n,&m))                   //表示可对多组数据进行重复操作
	{                           
		scanf("%s",str);                                //输入该段字符
		while(n--){
			scanf("%s %d %d",ch,&i,&j);                  //输入某字符的增删花费情况
			cost[ch[0]-'a'] = Min(i,j);                  //将该字符的增删花费的最小值存进cost(字符与26位字母顺序相统一,便于存储与使用)
		}
		for(j=1;j<m;j++)
		{
			for(i=j-1;i>=0;i--)
			{
				dp[i][j] = Min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a'])	;           //不匹配(不回文)时花费(等于增或删首项或尾项)
				if(str[i] == str[j])
				{
					dp[i][j] = Min(dp[i][j],dp[i+1][j-1]);           //匹配时(回文时)不进行花费,跳过该环节
				}

			}
		}
		printf("%d\n",dp[0][m-1]);                          //输出从1到m字符使之成为回文串的最小花费
		memset(dp,0,sizeof(dp));                          //进行下一组数据测试前,首先将上一组存留的数据花费清零
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42785226/article/details/89257214