poj-3280--Cheapest Palindrome(区间dp)

题目链接:http://poj.org/problem?id=3280

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题目大意:给出一个字符串,再给出每个字母增加/减少所需要的花费。判断将字符串构成一个回文串所需要的最少花费

要构成一个回文串,删除一个字符和增加一个字符所带来的效果一样,那么,我们选择最小的花费(删除或增加)

从小区间向大区间扩展;

状态转移方程:dp[i][j]=min( dp[i-1][j]+cost[i],dp[i][j+1]+cost[j] )

如果s[i]==s[j]          则向两边推一位

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);

char s[2010];
int arr[30],dp[2010][2010];

int main()
{
	std::ios::sync_with_stdio(false);
	int n,m;
	cin>>n>>m;
	cin>>s;
	for(int i=0;i<n;++i)
	{
		char ch;
		int a,b;
		cin>>ch>>a>>b;
		arr[ch-'a']=min(a,b);
	}
	for(int i=0;i<m;++i)
	{
		for(int j=i-1;j>=0;--j)
		{
			dp[i][j]=min(dp[i-1][j]+arr[s[i]-'a'],dp[i][j+1]+arr[s[j]-'a']);
			if(s[i]==s[j])
				dp[i][j]=min(dp[i][j],dp[i-1][j+1]);
		}
	}
	cout<<dp[m-1][0]<<endl;
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81584498