【POJ3280】Cheapest Palindrome(区间dp)

题目链接

Cheapest Palindrome

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions:13315   Accepted: 6299

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

【题意】

给一个长度为m的字符串,已经n个字符,可以任意增加给定字符或删除,增加或删除都要付出一定代价,输出将给定字符串变为回文串的最小代价。

【解题思路】

dp[i][j]表示第i个字符到第j个字符的最小代价。

(1)当str[i+1,j]为回文串时,dp[i][j]=min (dp[i+1][j]+add[i],dp[i+1][j]+del[j])

(2)当str[i,j-1]为回文串时,dp[i][j]=min (dp[i][j-1]+add[j],dp[i][j-1]+del[j])

(3)当str[i]=str[j]时,dp[i][j]=dp[i+1][j-1]。(即不需要增加或删除字符就是回文串了)

【代码】

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;
const int INF=0x3f3f3f3f;
int dp[2005][2005],add[35],del[35];
int main()
{
    int n,m,x,y;
    string str;
    scanf("%d%d",&n,&m);
    cin>>str;
    for(int i=0;i<n;i++)
    {
        getchar();
        char ch;
        scanf("%c%d%d",&ch,&x,&y);
        add[ch-'a']=x;
        del[ch-'a']=y;
    }
    for(int i=0;i<m;i++)dp[i][i]=0;
    for(int len=2;len<=m;len++)
    {
        for(int i=0;i<=m-len;i++)
        {
            dp[i][j]=INF;
            int j=i+len-1;
            if(str[i]==str[j])dp[i][j]=dp[i+1][j-1];
            dp[i][j]=min(dp[i][j],min(dp[i+1][j]+del[str[i]-'a'],dp[i+1][j]+add[str[i]-'a']));
            dp[i][j]=min(dp[i][j],min(dp[i][j-1]+del[str[j]-'a'],dp[i][j-1]+add[str[j]-'a']));
        }
    }
    printf("%d\n",dp[0][m-1]);
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/83901606